About extracting data

Extracting allows you to copy some or all of the records or fields from an ACL table to a new ACL table. The new table can be a subset of the records in the source table, a subset of the fields, or a subset of both. It can also be an identical copy containing all the source table records and fields. The existing sort order in the source table is maintained in the new table.

The difference between extracting all data, and copying a table in the Project Navigator ( Edit > Copy), is that extracting creates a new source data file (.fil) as well as a new table layout, whereas copying creates only a new table layout that remains associated with the original source data file.

The following are some of the reasons for extracting data to a new table:

Extracting by record, by view, and by fields

You have the option of extracting entire records, all the fields in a view, or a selection of individual fields. When you extract entire records, the record is copied exactly, including any data stored in undefined gaps in the table layout. When you extract all the fields in a view, or individual fields, any undefined portion of a record is ignored, even if you extract all the fields in the source table.

Computed fields remain as computed fields when you extract entire records. They are converted to physical fields of the appropriate data type, and populated with the actual computed values, when you extract the fields in a view or individual fields.

If a computed field contains local times with a UTC offset (for example, 23:59:59-05:00), the local times and UTC offset are preserved when you extract by record. When you extract by view or by fields, the local times and UTC offset are converted to UTC without an offset. For example, 23:59:59-05:00 becomes 04:59:59.

Extracting logical fields requires that Include Filters in Field Lists is selected (Tools > Options > Interface).

Additional details about extracting by view

Selecting the View option in the Extract dialog box allows you to extract exactly the data that is currently displayed in the active view. The following details apply when extracting by view:

Extracting data from server tables and local tables

You can extract data from both server tables and local tables. Data extracted from a server table can be saved to a table on the server, or on your local computer. Data extracted from a local table can be saved only to a table on your local computer.

Setting a control total

If you are extracting all the records in a table, or all the data in a view or a selection of fields, you can set a control total on a numeric field to verify that all the data is in fact extracted. You set a control total for a field in the Table Layout dialog box. Once you have extracted the data, in the new table select Tools > Table History to compare the input and output control totals. For more information, see Defining physical data fields.

Related tasks
Extracting data


(C) 2013 ACL Services Ltd. All Rights Reserved. | Send feedback