Creating data filters

Data filters are used to identify the record, or records, in a data file. Creating a data filter involves identifying rules that define the area of the data file that should be included in your ACL table, and exclude any data that should not be included. Data highlighted in black in the preview table is excluded, and data highlighted in white is included.

If there is an active data filter it is deactivated automatically when you create a new filter.

If you want to edit an existing data filter, you can edit it as a computed field in the Table Layout dialog box. To display data filters in the Table Layout dialog box, you must select the Include Filters in Field Lists option in the Interface tab in the Options dialog box (Tools > Options).

To create a data filter:

  1. Select Edit > Table Layout.
  2. Click the Add a New Data Filter tab.

    The contents of the data file are displayed in the data preview area in the bottom half of the screen. By default all data displayed is initially excluded. This is indicated by the “Exclude All” condition listed in the data filter list, which cannot be modified or deleted.

  3. Select a unique character or sequence of characters in the record to define the filter condition. Click an individual character to highlight it, or click and drag to select more than one character, and click Include to select all of the records that match the specified condition.

    For example, a data file might have the decimal point in byte position 71 of each row that should be included in your ACL table. You need to include this decimal point in your filter. If the decimal point is in the same position in any rows you do not want to include, you will need to create a rule to omit the incorrectly selected rows.

  4. If you want to exclude part of a selected record, select a unique character or sequence of characters in the record to define the filter condition and click Exclude.
  5. Click Accept Entry to create the data filter with the specified conditions.
  6. In the Save Filter As dialog box, enter a name for the filter and click OK.
  7. Click Yes in the Keep this filter active? dialog box to start defining the fields in the record. If you want to define the fields later click No, and select the filter from the drop-down list in the Edit Fields/Expressions tab when you want to define the fields.

    When the filter is active the areas of the data file that are excluded from the record are highlighted in black in the Edit Fields/Expressions preview table. Select the individual fields from the white areas of the preview table to add them to the record.

Related concepts
About data filters
Related tasks
Activating data filters


(C) 2013 ACL Services Ltd. All Rights Reserved. | Send feedback