User interface overview

The ACL user interface includes a number of elements, such as tabs, menus, text boxes, and dialog boxes, that display specific types of information. Understanding the organization of the user interface will enable you to work effectively with ACL.

Figure 1. ACL user interface

The user interface includes the following elements:

  1. Title Bar – The title bar displays the name of the active ACL project, the product name, and the version number.

  2. Main Menu – The main menu provides access to most ACL features including menu commands for working with ACL projects, performing audit analysis, and configuring options and connection settings.

  3. Toolbar – The buttons in the toolbar are shortcuts to common actions. ACL enables buttons that are relevant to your current activity. To display or to hide the toolbar, select Window > Tool bar.

    You can customize the buttons contained in the toolbar. For more information, see Customizing the toolbar.

  4. Navigator – The Navigator displays information in three tabs about the open ACL project:

    • The Overview tab displays all items that belong to the project. You can right-click any project item to perform an action. To organize items in the Overview, right-click the project icon and select New > Folder. You can drag any project item into the folders that you create in the Overview.

    • The Log tab displays the ACL command log, in which all actions you take associated with the project are recorded and organized chronologically. Double-click log entries to open them, and right-click log entries to perform an action.

    • The Variables tab displays the names, values, and data categories of any variables in the project. The contents of the tab are dynamically updated as variables are created, deleted, or changed in value. Variable names are listed alphabetically.

  5. Command Line – The command line allows you to enter ACLScript commands. To display the command line, if it is not visible, select Window > Command Line.

  6. Filter – The Filter text box and drop-down list allow you to apply a filter to the data displayed in the View tab. You can also enter one or more search terms to perform a quick search of the data.

  7. Index – The Index drop-down list allows you to apply existing indexes to the table and to see if an index is currently applied.

  8. Display Area – In this area, ACL displays different types of information in the following tabs:

    • View tab (shown) – When you open an ACL table the data is displayed in the View tab. If multiple views exist for the same table, buttons at the bottom of the tab let you switch between views.

      You can pin the View tab if you want to open more than one table. An additional View tab opens for each additional table you open. You can switch between tables using the individual View tabs.

      The record number column is at the far left of the View tab. The number of the currently selected record is highlighted in green.

    • Results tab – When you output results of an analytical operation to screen or graph, or view command log entries, they are displayed in the Results tab. For operations with text and graph output, buttons at the bottom of the tab let you switch back and forth between the two formats. You can pin the Results tab to keep the content visible and cause subsequent results to appear in an additional Results tab.

    • Script Editor tab – When you create a new script or open an existing script, the contents of the script are displayed in the integrated Script Editor. You can edit scripts manually, or use the tools available in ACL, such as syntax capture and copying commands from the log, to edit your script.

    • Workspace Editor tab – When you create a new workspace or open an existing workspace, the field definitions in the workspace are displayed in the Workspace Editor. Workspaces allow you to share field definitions among ACL tables.

  9. Status Bar – The status bar displays information such as the name of the active ACL table, the record count, the details of any filters currently applied to the table, and the name of any currently running script.

Command dialog boxes

When you select an ACL operation (ACL command) such as Summarize or Duplicates from the main menu, a command dialog box opens. These dialog boxes contain options that allow you to specify the input field or fields for the operation, the format of the output results, and a number of other options that affect the behavior of the operation.

The options in the dialog boxes vary somewhat depending on the operation you select, but there are a number of standard options, explained below, that appear for most operations. Depending on the operation, the options are organized on two or three tabs – the Main tab, and either the More tab or the Output tab, or both. The figures below show the three tabs in the Summarize dialog box.

Figure 2. Main tab in a command dialog box

Table 1. Standard options on the Main tab

Main tab option

Allows you to . . .

field list or lists

Specify the input field or fields for the operation

Subtotal Fields

Specify one or more numeric fields to optionally subtotal as part of the operation

Presort

Specify that the input field is automatically sorted before the operation is performed

If

Specify an IF statement that excludes records that do not meet the specified condition from the operation

To

Specify the name and location of the ACL table that will contain the output results

Appears on the Output tab (as Name) in command dialog boxes that have an Output tab

 

Figure 3. More tab in a command dialog box

Table 2. Standard options on the More tab

More tab option

Allows you to . . .

Scope All | First | Next | While

Specify how many records in a table are processed by an operation:

  • All – all records are processed

  • First – the specified number of records are processed, starting at the first record in the table

  • Next – the specified number of records are processed, starting at the currently selected record in the table

  • While – records are processed, starting at the first record in the table, as long as the WHILE statement evaluates to true

Use Output Table

Specify that an ACL table containing output results opens automatically upon completion of the operation

Appears on either the Main tab or the More tab.

Append To Existing File

Specify that output results contained in an ACL table or text file are added to the bottom of an existing ACL table or text file

 

Figure 4. Output tab in a command dialog box

Table 3. Standard options on the Output tab

Output tab option

Allows you to . . .

To Screen | Print | Graph | File

Specify the format of the output results:

  • Screen – displays the results in the ACL display area

  • Print – sends the results to the default printer

  • Graph – creates a graph of the results and displays it in the ACL display area

  • File – saves or appends the results to an ACL table or a file

Some operations do not support all four output formats

File Type

Specify an ACL table or a text file when you save output results to a file

Depending on the operation, you may be able to save to either a table or a text file, or to only one of these options

Name

Specify the name and location of the ACL table or text file that will contain the output results

Appears on the Main tab (as To) in command dialog boxes that do not have an Output tab

Local

Specify whether to save an ACL table with output results locally or to the server (only enabled when connected to a server table)

Appears on either the Main tab or the Output tab

Header

Specify a text header to accompany the output results

Not supported for all format types

Footer

Specify a text footer to accompany the output results

Not supported for all format types

Additional user interface elements

ACL also includes the following user interface elements, which are used to import and define data, work with tables, build expressions, insert custom dialog boxes into scripts, and work with analytics and analysis apps:



(C) 2015 ACL Services Ltd. All Rights Reserved.