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Working with SAP tables

Working with SAP queries

Retrieving SAP data

Configuring Direct Link

Automating Direct Link queries

1. Getting started
Direct Link enables you to locate and retrieve data from SAP ERP systems for further analysis in ACL.

Section contents
About Direct Link
Direct Link adds SAP ERP data selection and extraction capabilities to the data access, analysis, and reporting
capabilities of ACL. It allows you to connect to your SAP system and extract data for use in ACL.

User interface overview
When you work with Direct Link you will use the main window to create your queries.

Usage guidelines
Direct Link gives you the ability to perform queries on SAP tables, many of which contain large amounts of
data. You must use caution when querying your SAP ERP system.

Character encoding of SAP data
Direct Link enables users to work with both non-Unicode and Unicode SAP ERP systems. The way Direct Link
reads character fields from these systems depends on the edition of ACL you are using.

Starting Direct Link
You need to start ACL and log in to a SAP ERP system to use Direct Link.

1.1. About Direct Link
Direct Link adds SAP ERP data selection and extraction capabilities to the data access, analysis, and reporting
capabilities of ACL. It allows you to connect to your SAP system and extract data for use in ACL.

Direct Link extracts data based on queries you create by selecting tables, fields, and filters. Your SAP security
authorization determines which tables you can access. You can run your query immediately and download the
results to an ACL table, or you can run the query as a background process and store the extracted data on the
SAP server to retrieve later.

Creating a Direct Link query typically involves the following steps:

1. Connect to the SAP system and log in.

2. Add one or more tables to your query. If you add more than one table, you need to identify the
relationships between the tables.

3. Select the fields to include in the query.

4. Add filters to limit the results returned by the query.

5. Submit the query to the SAP system.

6. Use ACL to analyze the data produced by the query.

Benefits to your organization

The following are some of the advantages and benefits your company will gain from using Direct Link:

Empowers users – Direct Link provides direct and seamless access to SAP tables and displays additional
information about SAP fields and tables.

Saves time and resources – Direct Link reduces requests for customized ABAP extracts and extract
programs.
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Minimizes data analysis costs – Direct Link does not require any expensive middleware or hardware.
The product is quick to install and easy to learn, offering a rapid return on investment.

Ensures data integrity – Direct Link provides users with read-only access to the SAP source data,
which ensures that they cannot make changes to the original data.

Respects existing SAP security authorizations – Direct Link limits users to the tables in the SAP
system that they have the appropriate SAP security authorizations to view and extract data from.

1.2. User interface overview
When you work with Direct Link you will use the main window to create your queries.

Figure 1. Main Direct Link window

The main Direct Link window (Figure 1) includes the following user interface elements:

1. Main menu – The main menu provides access to all of the commands you can use to create, work with,
and save your queries.

2. Toolbar – The first row of the toolbar provides quick access to commonly used commands. The second
row allows you to specify the maximum number of rows a query can retrieve, and allows you to select
the extraction mode for the query.

3. Table treeview – The table treeview lists the tables included in the query.

4. Query tabs – There are three tabs in this area that list the following information:

Fields – This tab displays the fields that are available for inclusion in the query. Fields included in
the query are identified by a checkmark in the first column.

Filters – This tab displays the filter(s) that will be applied when the query is submitted.
Information about each filter includes the field being filtered on and the filter criteria.

Joins – This tab list the fields that are being used to join tables together.

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/#idb965e12f-43b6-442f-a8f4-a269a79a1292__BGDIGIDC
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5. Status bar – The status bar displays the number of fields selected and the estimated size of the query
results.

Related tasks
Configuring Direct Link options

1.3. Usage guidelines
Direct Link gives you the ability to perform queries on SAP tables, many of which contain large amounts of
data. You must use caution when querying your SAP ERP system.

You may negatively impact the performance of the SAP system if you create a query that retrieves all of the
records from a table, or group of tables. You should adhere to the following guidelines to minimize your impact
on the SAP system:

Understand your data. If you are not sure of the table data you want, research prior to constructing your
query. Perform small queries (first 100 records without filters) until you are confident that you have
isolated the data you want. Once you have isolated the data, you can retrieve the full data set.

Whenever possible, construct queries that join tables, or filter, on columns that are indexed to improve
query performance.

Refine your query on a test system (if you have access to one), prior to submitting it to the production
system.

Avoid submitting queries during peak usage periods for the SAP system. Consult your SAP Basis
Administrator to determine your company’s peak hours.

Consult your SAP Basis Administrator prior to submitting large queries. There may be a preferred time to
submit large queries.

Retrieve the results of your background queries. Files not retrieved take up excessive room on the SAP
server, and the Direct Link directory may run out of space.

1.4. Character encoding of SAP data
Direct Link enables users to work with both non-Unicode and Unicode SAP ERP systems. The way Direct Link
reads character fields from these systems depends on the edition of ACL you are using.

ACL Unicode Edition

If you are using the Unicode edition of ACL, data is always read directly from the SAP system. When you
connect to a Unicode SAP system, data is downloaded as Unicode and displayed as Unicode data in ACL. When
you connect to a non-Unicode system, data is downloaded in the code page it is encoded in and displayed in
ACL using that code page. The Unicode edition of ACL supports ASCII, EBCDIC, and Unicode character data.

ACL Non-Unicode Edition

If you are using the non-Unicode edition of ACL to access a SAP system, the behavior depends on the type of
system you are accessing. If you access a non-Unicode SAP system, data is downloaded in the code page it is
encoded in and displayed in ACL using that code page.

If you access a Unicode SAP system, the Unicode SAP fields must be converted before they can be read in ACL
because the non-Unicode edition of ACL does not include a Unicode data type. When you run a Direct Link
query on a Unicode SAP system from the non-Unicode Edition of ACL, character fields are converted from
Unicode to ASCII fields when the query results are extracted from the SAP system. The character encoding of
the computer that submits the query determines the code page used to encode the results of the query. For
example, if you submit a query to a Unicode SAP system from a workstation where the language is set to
English (United States), the code page will be set to Windows-1252, which is the code page for displaying
English ASCII characters in Windows.

You need to keep the following points in mind if you need to import data from a Unicode SAP system with the
non-Unicode edition of ACL:

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/t_configuring_direct_link_options.html
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The Regional and Language Options settings in the Windows Control Panel determine the code page
setting on the computer. Direct Link gets this code page information when a query is submitted and
converts the data from Unicode to the appropriate code page when the data is extracted.

If the characters in your SAP data span more than one code page (e.g., a column has some rows with
Russian text and others with Chinese text) some of the data (i.e., the text that doesn’t use the code page
the computer is set to) will not be interpreted correctly and will be displayed as unrecognizable
characters.

The record length and field length cannot be calculated accurately for double-byte code pages that do not
always use two characters.

If a character cannot be converted to the destination code page, it will be replaced by a number sign
character (#).

Only text fields are affected by code page conversions. Numeric and datetime fields are not affected.

1.5. Starting Direct Link
You need to start ACL and log in to a SAP ERP system to use Direct Link.

To start Direct Link:

1. Open ACL.

2. Do one of the following:

Select Data > External Data > SAP > Create Query.

Select File > New > Table to start the Data Definition Wizard. If the Select Platform for
Data Source page is displayed, select Local and click Next. In the Select Local Data Source
page, select SAP and click Next to launch Direct Link.

Click Create Query  in the ACL toolbar (if you have customized the toolbar to include this
option).

3. In the Logon dialog box, select the SAP system you want to connect to and click OK.

4. In the SAP Logon dialog box, enter the following information:

User name – The username required to access the SAP system.

Password – The password required to access the SAP system.

Client – The number assigned to the SAP subsystem you want to connect to.

Language – The one or two letter character code for the language you want to use to access the
SAP system. The code must correspond to a language configured on the SAP system.

Note
The information required in the SAP Logon dialog box is the same as the
information required to log in to the SAP system through the SAP Logon
Pad.

5. Click OK.

If you log in successfully, Direct Link starts and the Add Table dialog box is displayed.

2. Working with SAP tables
The topics in this section cover the information you need to know to use Direct Link to select the tables you
need from the SAP system, and to identify the relationships between related tables in the SAP system.

Section contents
About SAP tables
Direct Link enables you to create queries that allow you to access data from all of the tables you have been
granted rights to in a SAP ERP system.

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/c_about_sap_tables.html
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Adding tables by searching
You can use the Search tab to locate the data you need in the SAP system. You can search for tables by table
name or description, or for fields by field name or description.

Adding tables by browsing
You can use the Application Areas tab to browse tables in the SAP system by application area.

About related tables
Related tables allow you to include fields from a number of SAP tables in your ACL table. After you add a parent
table to your query, you can add related tables to it.

Adding related tables
You can use the Related tab in the Add Table dialog box to add tables that are related to the parent table.

About joining tables
Direct Link enables you to join two related tables in the SAP system as a single table in your query.

Joining tables manually
You can create a join between two tables with related information when you want to include information from
both tables in a single ACL table. You can join tables on a single column, or on more than one column.

Editing joins
You can edit a join if you want to change the column in the parent table or child table that is included in the
join.

Deleting joins
You can delete a join between the parent table and child table if you do not want to link the tables based on the
specified column.

Viewing indices
You can use the Indices dialog box to view the indexes that are associated with the selected table.

Deleting tables
You can delete tables from your query if you add the wrong table from the SAP system, or if you added a table
you do not want to include.

2.1. About SAP tables
Direct Link enables you to create queries that allow you to access data from all of the tables you have been
granted rights to in a SAP ERP system.

Direct Link provides several ways to locate and access the data you need in your SAP system. You can use the
Add Table dialog box to search for particular tables or fields, or you can browse for particular tables by the
application area they are associated with in the SAP system.

After you add a parent table to your query, you can use the Related tab to select child tables that have
common columns with the parent table. A parent table is the main table for your query, and is also the first
table you add. Child tables are tables that share common columns with the parent table. You can select child
tables to join to the parent table to create a single table in ACL with data from both SAP tables.

Related tasks
Adding tables by searching
Adding tables by browsing
Deleting tables

2.2. Adding tables by searching
You can use the Search tab to locate the data you need in the SAP system. You can search for tables by table
name or description, or for fields by field name or description.

The tables you can access depend of the level of your SAP security authorization. Restricted tables are not
displayed in the search results. Contact your SAP Basis Administrator if you want to request access to restricted
tables.

To add a SAP table by searching:

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/t_adding_tables_by_searching.html
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1. Select Tables > Add.

2. In the Add Tables dialog box, click the Search tab.

3. Select one of the following options from the Search by drop-down list:

Table Name – Searches the names of SAP tables.

Table Description – Searches the descriptions of SAP tables.

Field Name – Searches the names of fields in SAP tables.

Field Description – Searches the descriptions of fields in SAP tables.

4. Enter the search string you want to find in the Search for text box.

You can enter the exact string, or you can use the wildcard character (*) and enter only part of the name
or description you are searching for. If you do not use the wildcard character, the search only locates
tables that exactly match the search string. The search string is case-sensitive for table description and
field description searches. It is not case-sensitive for table name and field name searches.

Tip

If you leave the Search for text box blank, the system displays all of the
table names you are authorized to view.

5. Select the table types you want to search from the following list. All table types are selected by default.

Transparent – Logical tables that have the same structure as the underlying physical table
structure. Transparent tables typically store data that has commercial relevance.

Pooled – Logical tables in the ABAP Dictionary that are assigned to a table pool. Pooled tables are
used to store internal application data, such as screen sequences, program parameters, and
documentation.

Clustered – Logical tables that are assigned to a table cluster. Clustered tables are used to store
internal application data, such as screen sequences, program parameters, and documentation.

Views – Virtual tables created from the results of stored queries. Views can include a subset of the
data in a single table, or data from multiple physical tables joined into a single virtual table.

6. Click Search.

7. Select the table to add to your query from the list of results and click OK.

Related concepts
About SAP tables

2.3. Adding tables by browsing
You can use the Application Areas tab to browse tables in the SAP system by application area.

Browsing for tables is useful when you do not know, or cannot remember, the name of a particular table, but
you know the type of data it contains.

A lock icon  is displayed next to any application areas that you do not have the necessary SAP security
authorizations to access. To request access to restricted tables, contact your SAP Basis Administrator.

To add a SAP table by browsing:

1. Select Tables > Add.

2. In the Add Tables dialog box, click the Application Areas tab.

3. Navigate through the treeview and select the table you want to add to your query.

4. Click OK.

Related concepts
About SAP tables

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/c_about_sap_tables.html
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2.4. About related tables
Related tables allow you to include fields from a number of SAP tables in your ACL table. After you add a parent
table to your query, you can add related tables to it.

Normally, you can add up to seven tables in a query, including the parent table. However, if you add a clustered
or pooled table to your query, the maximum is five tables. A related table is also called a child table.

In Direct Link, a table can be a related table if it meets one, or both, of the following criteria:

There must be at least one corresponding field in the child table’s primary key and the primary key of the
parent table.

There must be a relationship between the child table and the parent table in the SAP data model.

Related tasks
Adding related tables

2.5. Adding related tables
You can use the Related tab in the Add Table dialog box to add tables that are related to the parent table.

The Related tab is only enabled after you add a parent table.

To add a related table:

1. Select Tables > Add.

2. In the Add Child Table dialog box, select the related table to add and click OK.

3. In the Selected Joins dialog box, click Yes to join the tables on the column(s) Direct Link has identified,
or click No to create the join manually.

4. If you clicked No in the previous step, you need to complete the following steps to manually create at
least one join between the tables in the Add Join dialog box:

a. Select the field you want to include in the join from the Parent drop-down list.

b. Select the field you want to include in the join from the Child drop-down list.

c. Click OK.

5. If you need to join the table on additional fields, select Joins > Add and specify the appropriate columns
in the Parent and Child drop-down lists and click OK.

Related concepts
About related tables

2.6. About joining tables
Direct Link enables you to join two related tables in the SAP system as a single table in your query.

The join type used in Direct Link is an inner join, which requires each record in the child table to have a
matching record in the parent table.

When you add a related child table to a master table, Direct Link compares the primary key fields in the two
tables. If any of the fields match, Direct Link displays a dialog box suggesting that you join the tables on the
matching fields.

Tip

You can configure Direct Link to automatically join the tables on the matching
fields by selecting the Accept system suggested joins checkbox in the
Options dialog box. If this option is selected the Suggested Joins dialog
box will not be displayed.

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/t_adding_related_tables.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/c_about_related_tables.html
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Direct Link suggests columns to use to join tables by applying rules to compare the columns in the two tables.
In some cases, you will want to join the tables on these suggested fields. In many cases, however, you need to
understand your data so you can determine whether some, or all, of the suggested fields should be included in
the join. You can accept the suggested join and delete the joins that are not required, or you can join the tables
manually on some of the suggest fields, or you can select different fields to join the tables on. If Direct Link
does not identify any matching fields, you need to select the fields to join the tables on. The fields you join on
must be of the same type and size, but the names can be different.

The Joins tab lists the fields used to join the parent and child tables.

Related tasks
Joining tables manually
Editing joins
Deleting joins
Configuring Direct Link options

2.7. Joining tables manually
You can create a join between two tables with related information when you want to include information from
both tables in a single ACL table. You can join tables on a single column, or on more than one column.

You must add a parent table, and at least one child table, before the Joins > Add menu item is enabled.

To create a join manually:

1. In the Direct Link window, select the child table you want to join to the parent table in the table treeview.

2. Select Joins > Add.

3. In the Add Join dialog box, select the field you want to join on from the Parent drop-down list, and then
select the corresponding column in the related table from the Child drop-down list.

4. Click OK.

Related concepts
About joining tables

2.8. Editing joins
You can edit a join if you want to change the column in the parent table or child table that is included in the
join.

To edit a join:

1. In the Direct Link window, select the child table you want to remove the join from in the table treeview.

2. Select the Joins tab.

3. Select the join you want to edit.

4. Select Joins > Edit.
5. Modify the selected columns in the Edit Join dialog box and click OK. You must ensure that the selected

columns have the same data type and length.

Related concepts
About joining tables

2.9. Deleting joins
You can delete a join between the parent table and child table if you do not want to link the tables based on the
specified column.

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/t_joining_tables_manually.html
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If you remove the last join from a child table, a message is displayed indicating that the child table will be
removed.

To delete a join:

1. In the Direct Link window, select the child table you want to remove the join from in the table treeview.

2. Select the Joins tab.

3. Select the join(s) you want to delete. You can select an individual join, or Ctrl+click to select multiple
joins.

4. Select Joins > Delete.

5. Click Yes in the confirmation dialog box.

Related concepts
About joining tables

2.10. Viewing indices
You can use the Indices dialog box to view the indexes that are associated with the selected table.

You can use this information to optimize the speed of your query if the columns the tables are joined on, or
filtered on, correspond to the columns in an index. A table is always indexed on the primary key columns, but
one or more additional indexes may be associated with a table.

To view the indices for a table:

1. In the Direct Link window, select the table you want to view indices for in the table treeview.

2. Select Tables > Show Indices to display the Indices dialog box.

If any indexes are associated with the table, they are displayed in the Indexes for [table name] dialog
box. If the dialog box is empty, no additional indexes are associated with the table.

3. When you have finished viewing the indices, select Tables > Show Indices again to close the dialog
box.

2.11. Deleting tables
You can delete tables from your query if you add the wrong table from the SAP system, or if you added a table
you do not want to include.

To delete a table from your query:

1. In the Direct Link window, select the table you want to delete in the table treeview.

2. Select Tables > Delete.

3. Click Yes in the confirmation dialog box.

Related concepts
About SAP tables

3. Working with SAP queries
The topics in this section cover the information you need to know to create queries in Direct Link to retrieve
SAP data.

Section contents
Opening existing queries
You can open previously saved queries in Direct Link if you want to submit them to the SAP system again, or
use them as a starting point for creating a new query.

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/c_about_joining_tables.html
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Displaying queries
You can view the SQL statement used by Direct Link to select data from the SAP system.

Saving queries
You can save the queries you create in Direct Link whenever necessary.

About fields
The Fields tab displays all of the columns in the selected SAP table. The Fields tab indicates each field’s SAP
data type and the equivalent ACL data type.

Selecting fields
After you add one or more tables to your query, you need to select the fields to include in the query.

About filters
You can use filters to extract a subset of records from a SAP table based on the criteria you specify.

Adding individual filters
You can create filters to restrict the records returned from SAP tables based on specific criteria.

Adding multiple filters
If you need to filter on several values in a field, such as a list of client ID numbers, you can use the Add List
command to create several filters for the field at once.

Editing filters
You can edit filters in the Filters tab if you want to modify the results returned by your query.

Deleting filters
You can delete filters from the Filters tab if you want to remove restrictions placed on your query.

3.1. Opening existing queries
You can open previously saved queries in Direct Link if you want to submit them to the SAP system again, or
use them as a starting point for creating a new query.

To open an existing query:

1. Select File > Open.

Note
If you already have a query open with unsaved changes, you will be
prompted to save the changes.

2. In the Open dialog box, select the Direct Link query you want to use and click Open.

3.2. Displaying queries
You can view the SQL statement used by Direct Link to select data from the SAP system.

Viewing the SQL syntax used in the query can assist with troubleshooting if you do not get the results you
expect when you run the query.

To display a query:

1. Select Query > Show.

2. When you have finished viewing the query, click OK to close the Show Query dialog box.

3.3. Saving queries
You can save the queries you create in Direct Link whenever necessary.

To save a query:

1. Select File > Save.

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/t_displaying_queries.html
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Changes to previously saved queries will be saved automatically to their save location in the file system.
If the queries has not been saved yet, the Save As dialog box is displayed.

2. If the Save As dialog box is displayed, select the folder to save the query in, enter a file name, and click
Save.

3.4. About fields
The Fields tab displays all of the columns in the selected SAP table. The Fields tab indicates each field’s SAP
data type and the equivalent ACL data type.

Table 1 lists the supported SAP data types, and the corresponding data types for both the non-Unicode and
Unicode editions of ACL. When extracting fields, Direct Link converts SAP data types into the equivalent ACL
data types.

Direct Link displays the following information about each field in the Fields tab:

Name – The name of the field.

Description – The description of the field.

SAP Data Type – The SAP data type of the field in the SAP system.

ACL Data Type – The ACL data type that corresponds to the SAP data type.

Length – The field length specified as the number of bytes. For non-Unicode data, this value is
equivalent to the number of characters. For Unicode data, this value is double the number of characters,
since each character is represented by two bytes.

Decimals – The number of decimal places included. This value is only displayed for numeric types.

Table 1. SAP to ACL field mappings

SAP Data
Type

ACL Data
Type

ACL Unicode Data
Type

Description

ACCP ASCII Unicode Posting Period YYYYMM

CHAR ASCII Unicode Character string

CLNT ASCII Unicode Client

CUKY ASCII Unicode Currency key, referenced by CURR
fields

CURR Print Print Currency field, stored as DEC

DATS Datetime Datetime Date field (YYYYMMDD) stored as
char(8)

DEC Numeric Numeric Counter or amount field with
comma sign

FLTP ASCII Unicode Floating point numeric, accurate
to 8 bytes

INT1 Numeric Numeric 1-byte integer, integer number
<=254

INT2 Numeric Numeric 2-byte integer

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/#id9ce13a78-ae2b-4088-a654-10b7d2e5f4ad__CJDCFIGC
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SAP Data
Type

ACL Data
Type

ACL Unicode Data
Type

Description

INT4 Numeric Numeric 4-byte integer, signed integer

LANG ASCII Unicode Language key

LCHR ASCII Unicode Long character string

LRAW Unsupported Unsupported Long byte string

NUMC ASCII Unicode Character string with only digits

PREC Numeric Numeric Precision of a QUAN field

QUAN Numeric Numeric Quantity field

RAW Unsupported Unsupported Uninterpreted sequence of bytes

RAWSTRING Unsupported Unsupported Byte string of variable length

SSTRING Unsupported Unsupported Short character string of variable
length

STRING Unsupported Unsupported Character string of variable length

TIMS Datetime Datetime Time field (hhmmss), stored as
char(6)

UNIT ASCII Unicode Unit key for QUAN fields

VARC ASCII Unicode Long character string

Related tasks
Selecting fields

3.5. Selecting fields
After you add one or more tables to your query, you need to select the fields to include in the query.

You should only select the fields that you want to include in your ACL table when the data is imported into ACL.

To select fields:

1. Click the Fields tab if it is not already displayed.

2. Choose the appropriate option(s) from the following list to select the fields to include in your query:

Select or deselect individual fields by clicking the checkbox in the first column.

Select all fields by selecting the checkbox in the first column header, or by selecting Edit > Select
All Fields.

Deselect all fields by deselecting the checkbox in the first column header, or by selecting Edit >
Deselect All Fields.

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/t_selecting_fields.html
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Related concepts
About fields

3.6. About filters
You can use filters to extract a subset of records from a SAP table based on the criteria you specify.

For example, you can use a filter to create a query that only returns records created after a certain date, or
records where the filtered column is over a certain value.

You need to keep the following points in mind when creating filters:

All filter values are case-sensitive.

The format used in date and time fields in the Add Filter dialog box corresponds to your Windows date
and time settings. To change the date and time format in Direct Link, you need to modify the date and
time settings in the Regional and Language Options dialog box, which you can access through the
Windows Control Panel.

Related tasks
Adding individual filters
Adding multiple filters
Editing filters
Deleting filters

3.7. Adding individual filters
You can create filters to restrict the records returned from SAP tables based on specific criteria.

To add a filter:

1. Select Filters > Add.

2. Select the field you want to filter on from the Field drop-down list.

3. Select the appropriate operator from the Operator drop-down list.

4. Enter the appropriate values in the Low and High text boxes.

The selected operator determines the requirements of the Low and High fields. The High field is only
enabled when the Between operator is selected.

Table 1 lists the fields you are required to complete for each operator and the data types supported. If
you use the Contains operator, you must include at least one wildcard character (*) with your filter value.
For example, to locate all records where the letter E is the last character in the field, you need to enter
*E in the Low field.

5. Click OK.

The new filter is added to the Filters tab.

Table 1. Filter operators
Operator Name Low field High field Data types

supported

= Equal to Required Not
applicable

All types

<> Not equal to Required Not
applicable

All types

< Less than Required Not
applicable

All types

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/c_about_fields.html
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Operator Name Low field High field Data types
supported

<= Less than or equal
to

Required Not
applicable

All types

> Greater than Required Not
applicable

All types

>= Greater than or
equal to

Required Not
applicable

All types

Between Between Required Required All types

Contains Contains Required Not
applicable

ASCII or Unicode
only

Related concepts
About filters

Related tasks
Adding multiple filters
Editing filters
Deleting filters

3.8. Adding multiple filters
If you need to filter on several values in a field, such as a list of client ID numbers, you can use the Add List
command to create several filters for the field at once.

When you create a filter list, the equal to (=) operator is selected by default, but you can change the operator
value for individual filter entries after they are created.

To add multiple filters:

1. Select Filters > Add List.

2. Select the SAP column you want to filter on from the Field drop-down list.

3. In the Filter List text box, enter each filter entry on a new line.

4. Click OK.

Each filter entry in the Filter List text box is created as an individual entry in the Filters tab. Once the
filters are created, you can edit them as necessary. For example, you can change the operator type.

Related concepts
About filters

Related tasks
Adding individual filters
Editing filters
Deleting filters

3.9. Editing filters
You can edit filters in the Filters tab if you want to modify the results returned by your query.

To edit a filter:

1. Select the filter from the list, then select Filters > Edit.

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/c_about_filters.html
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2. Modify the filter values, as necessary, and click OK.

Related concepts
About filters

Related tasks
Adding individual filters
Adding multiple filters
Deleting filters

3.10. Deleting filters
You can delete filters from the Filters tab if you want to remove restrictions placed on your query.

To delete a filter:

1. In the Filters tab in the main window, select the filter you want to delete.

2. Select Filter > Delete.

3. Click Yes in the confirmation dialog box.

Related concepts
About filters

Related tasks
Adding individual filters
Adding multiple filters
Editing filters

4. Retrieving SAP data
The topics in this section cover the information you need to know to retrieve the data produced by your SAP
queries.

Section contents
About submitting queries
There are two modes you can use to submit your queries using Direct Link: Extract Now mode and Background
mode. These modes determine how data is extracted from the SAP ERP system.

Submitting queries in Extract Now mode
You should submit queries in Extract Now mode when you want to immediately display the results of a small
query (less than 488KB) in a new ACL table.

Submitting queries in Background mode
You should submit queries in Background mode if the results of the query are greater than 488KB.

Retrieving Background mode query results
Before you can view the results of a Background mode query in ACL, you need to retrieve the result data from
the SAP system.

Refreshing SAP data
You can update contents of an ACL table that was originally created by a Direct Link query with current data
from the SAP system.

4.1. About submitting queries
There are two modes you can use to submit your queries using Direct Link: Extract Now mode and Background
mode. These modes determine how data is extracted from the SAP ERP system.

When you submit a query, you must select one of these modes:
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Extract Now – When this mode is selected, data is automatically retrieved from the SAP system and
displayed in an ACL table. This mode is recommended for data extracts that are 488KB or less. You
cannot perform other tasks in ACL while the query is running.

Background – When this mode is selected, the SAP system stores the extracted data in a file for you to
download at a later time. This mode is recommended for data extracts larger than 488KB. You can
perform other tasks in ACL while the query is running.

Related tasks
Submitting queries in Background mode
Retrieving Background mode query results
Submitting queries in Extract Now mode

4.2. Submitting queries in Extract Now mode
You should submit queries in Extract Now mode when you want to immediately display the results of a small
query (less than 488KB) in a new ACL table.

You should use Background mode for queries that return larger result sets.

To submit a query in Extract Now mode:

1. In the Direct Link window, select Extract Now from the Mode drop-down list.

2. Select Query > Submit.
3. In the Save As dialog box, enter the file name for the ACL data file, modify the location if necessary, and

click Save.

4. Enter a name for your new ACL table and click OK.

The results of the query are displayed in the new ACL table.

Related concepts
About submitting queries

4.3. Submitting queries in Background mode
You should submit queries in Background mode if the results of the query are greater than 488KB.

Displaying the results of a Background mode query in ACL is a two-step process. First, you need to submit the
query in background mode, and then after the query runs you need to retrieve the query results from the SAP
system.

To submit a query in Background mode:

1. In the Direct Link window, select Background from the Mode drop-down list.

2. Select Query > Submit.
3. In the Save As dialog box, enter the file name for the ACL data file, modify the location if necessary, and

click Save.

4. Enter a name for your new ACL table and click OK.

The ACL table and associated ACL data file are created, but the data file is empty until you retrieve the
results of the query from the SAP system. The SAP system stores the extracted data in a file for you to
retrieve when the query is complete.

Related concepts
About submitting queries

Related tasks
Retrieving Background mode query results
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4.4. Retrieving Background mode query results
Before you can view the results of a Background mode query in ACL, you need to retrieve the result data from
the SAP system.

Tip

If you know the name of the ACL table associated with the Background mode
query you want to retrieve, you can double-click the table in the Overview
tab in ACL to retrieve the query results from the SAP system.

To retrieve the results for a background query:

1. Do one of the following:

Select Data > External Data > SAP > Retrieve Query Results.

Click Retrieve Query Results  in the ACL toolbar (if you have customized the toolbar to
include this option).

2. In the Retrieve Query Results dialog box, select the table layout to retrieve and click Retrieve.

3. In the SAP Logon dialog box, enter your password for accessing the SAP system and click OK.

The results of the background query are downloaded from the SAP system and displayed in the
associated ACL table.

Related concepts
About submitting queries

Related tasks
Submitting queries in Background mode

4.5. Refreshing SAP data
You can update contents of an ACL table that was originally created by a Direct Link query with current data
from the SAP system.

Refreshing an ACL table that was created using Direct Link will re-execute the Direct Link query used to create
the table.

To refresh SAP data in an ACL table:

1. In the Overview tab in the ACL Project Navigator, right-click the table you want to refresh and select
Refresh from Source.

2. Click Yes in the confirmation dialog box.

3. In the SAP Logon dialog box, enter your password for accessing the SAP system and click OK.

The ACL table is updated with current data from the SAP system.

Related reference
REFRESH command

5. Configuring Direct Link
You can customize the default behavior of Direct Link, such as the way queries are submitted and the default
settings for the Add Tables dialog box. You can also add Direct Link commands to the ACL toolbar.

Section contents
Configuring Direct Link options
You can modify the default behavior of Direct Link in the Options dialog box.
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Customizing the ACL toolbar
You can customize the ACL toolbar to include the Direct Link-specific Create Query and Retrieve Query
Results toolbar buttons.

5.1. Configuring Direct Link options
You can modify the default behavior of Direct Link in the Options dialog box.

To modify the default Direct Link options:

1. In the Direct Link window, select Edit > Options.

2. Specify the default options for the way SAP queries are handled in the Query Submission panel:

Mode – Specify the default extraction mode.

Maximum Rows – Specify the default maximum number of records that queries return. The
default value is 500.

3. Specify the default options for the Add Tables dialog box in the Add Table Dialog panel:

Default Tab (master) – The tab selected by default when the dialog box is displayed before
adding a master table.

Default Tab (child) – The tab selected by default when the dialog box is displayed.

Next n rows – The number of results to display when searching for tables in the dialog box. The
value entered in this field is used in the button label in the dialog box. For example, if you enter
100 the button is called Next 100, and each time you click the button, the next 100 results from
the query are displayed.

Select all fields on add – Specifies that all fields in the table should be automatically selected in
the Fields tab when a table is added using the dialog box. If this option is not selected, none of
the fields are selected when a table is added to a query.

4. Specify miscellaneous Direct Link options in the Other panel:

Descriptive column headers – Display the field descriptions, rather than the field names, for the
column headings of extract results.

Accept system suggested joins – Automatically use the primary key fields identified by Direct
Link to join tables.

Prompt to save query – Direct Link will prompt you to save queries before they are submitted, if
they have changes.

Sort by field descriptions – Field lists in the Add Filter and Add Join dialog boxes will be
automatically sorted by field description. If this option is not selected, field lists will be sorted by
field name.

Allow empty tables – Specifies that an empty table will still be created in ACL for queries that do
not return any results. If this option is not selected, an error message is displayed when queries do
not return any results.

Refresh Logon Pad – Click this button to update the information displayed in the Direct Link
Logon dialog box with the current SAP system information configured in the SAP Logon Pad.

5. Click OK.

Related concepts
User interface overview

Related tasks
Customizing the ACL toolbar

5.2. Customizing the ACL toolbar
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You can customize the ACL toolbar to include the Direct Link-specific Create Query and Retrieve Query
Results toolbar buttons.

Clicking the Create Query toolbar button launches Direct Link and displays the Logon dialog box. Clicking the
Retrieve Query toolbar button displays the Retrieve Query Results dialog box, which you can use to
retrieve the results of queries run in Background mode from the SAP system.

To customize the ACL toolbar with Direct Link commands:

1. Select Tools > Customize.

2. In the Customize Toolbar dialog box, complete one, or both, of the following steps:

Select Create Query in the Available Toolbar Buttons list and click Add.

Select Retrieve Query Results in the Available Toolbar Buttons list and click Add.

3. If you want to rearrange the order of the toolbar buttons, select the button you want to reorder and click
Move Up or Move Down.

4. Click Close.

The new commands are added to the ACL toolbar.

Related tasks
Configuring Direct Link options

6. Automating Direct Link queries
You can use ACLScript commands to define ACL tables from SAP ERP data, refresh existing ACL tables, and
optionally retrieve the results of background mode queries.

Section contents
About ACLScript commands
You can use ACLScript commands to automate data access and analysis of Direct Link data, enabling you to
automate repetitive tasks and standardize processes.

IMPORT SAP command
Use this command to define ACL tables by importing data from SAP ERP systems.

RETRIEVE command
Use this command to retrieve the results of Direct Link queries submitted for background processing.

REFRESH command
Use this command to refresh the data in ACL tables that were originally created by Direct Link queries.

6.1. About ACLScript commands
You can use ACLScript commands to automate data access and analysis of Direct Link data, enabling you to
automate repetitive tasks and standardize processes.

You can use the following Direct Link-specific ACLScript commands to access SAP data in your scripts:

IMPORT SAP – Defines an ACL table based on a query that retrieves data from one or more SAP ERP
tables.

RETRIEVE – Retrieves the results of a query that was previously submitted for background processing.

REFRESH – Refreshes the results of a pre-existing query in a script.

You can create scripts that Direct Link-specific commands and other ACLScript commands to preform additional
data access or analysis tasks. For information about creating scripts, see “Working with scripts” in the ACL
Analytics User Guide. For more information about ACLScript, see the ACL Language Reference.

Related reference
IMPORT SAP command
RETRIEVE command

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/t_configuring_direct_link_options.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/c_about_aclscript_commands.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/r_import_sap.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/r_retrieve.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/r_refresh.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/r_import_sap.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/r_retrieve.html
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REFRESH command

6.2. IMPORT SAP command
Use this command to define ACL tables by importing data from SAP ERP systems.

Syntax
IMPORT SAP PASSWORD <n> TO <table_name> SOURCE "SAP AGENT" <import_details>

Parameters

PASSWORD n

Specifies the password required to access the SAP system. If the required password value is not defined
before the IMPORT SAP command is executed, ACL will prompt the user for their SAP password.

Tip

Use the SET PASSWORD command to define the password in the script before
using the IMPORT SAP command, or specify the password on the
command line before running the script.

TO table_name

The name of the table to create in ACL when the query is completed.

SOURCE “SAP AGENT”

A required parameter for importing SAP data. “SAP AGENT” is the only available option.

import_details

Contains the details of the query. The import_details string is composed of many tags, which are
enclosed by the <q></q> tags. Because a query can be very complex, this string may be up to 16KB in
length.

Remarks

The easiest way to insert an IMPORT SAP command into a script is to copy a complete IMPORT SAP command
from the command log. Because the import_details parameter can be very long (up to 16 KB), it is usually
impractical to type the entire command manually. You can import a table into ACL using the Data Definition
Wizard, and then copy the appropriate line from the Log tab and paste it into your script. You can then edit
the command, as necessary, in the script window.

The import_details parameter is the portion of the IMPORT SAP command that describes the query. Table 1
describes the usage of each tag and indicates when tags are required. The Required column in the table
indicates when the tag must be present using the following values:

Y = Required

N = Optional

M = Required for multi-table queries only.

B = Required, but no value should be passed.

W = Optional when filters are utilized.

Table 1. Direct Link query tags

Name Tag Required Description

Table Alias <a> M The alias that uniquely identifies the table within
the query. This allows the same table to be used
more than once.

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/r_refresh.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/#id700dd8f1-409a-4a3a-bd2d-560e0be4781e__CEHCGGAH
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Name Tag Required Description

All Rows <ar> Y Indicates that all matching rows should be
returned as part of the query’s result set. A value
of 1 overrides the value Maximum rows. A value of
0 returns the number of records specified in the
<r> tag.

This tag always appears after the <r></r> tag.

Client <c> N The client within the SAP system.

Child Table
Alias

<ca> M The alias of the child table.

Child Table
Field

<cf> M The field in the child table that the join condition is
based on.

Client
Filename

<cf> Y Identifies the target file on the client system where
the results of the query will be stored.

Child Table <ct> M The child table in the join condition.

Destination <d> N Identifies a destination in the saprfc.ini file that is
used by the SAP RFC libraries to locate an SAP
system.

Data Length <dl> B The number of characters in each row, including
the carriage return and line feed characters
(CR+LF or the hexadecimal characters OD+

OA) that are inserted at the end of each record to
indicate the end of the record.

Expected
Rows

<e> B The expected number of rows the query will
return.

Field Name <f> Y The native field name.

Filter Field <f> W The native field name that the filter applies to.

Fields <fs> Y The list of fields in the table that will be returned
as part of the query results.

High Value <h> W Contains the high value when using the Between
operator. Ignored when using any other operator.

Join
Condition

<jc> M The join condition.

Job Count <jcount> B Used internally by SAP to identify a Background
mode query.

Job Name <jname> B Used internally by SAP to identify a Background
mode query.



3/9/2020 Direct Link User Guide

https://help.highbond.com/acl/dl/61/advanced/print.jsp?topic=/com.acl.dl.user_guide.help/ui/home.html&cp=1 23/27

Name Tag Required Description

Join
Relationships

<js> Y The list of join conditions that link tables within the
query.

Low Value <l> W Contains either the lowest value when using the
Between operator or the value when using any
other operator.

Language <lg> N Language identifier used to determine the locale of
fields in the SAP database.

Mode <m> Y Numeric equivalent of the submission mode
enumerated type. Valid values are:

0 – Extract Now

1 – Background

Table Name <n> Y The native table name.

Operator <o> W Numeric equivalent of the operator enumerated
type. Valid values are:

0 – Equal to (=)

1 – Not equal to (<>)

2 – Less than (<)

3 – Less than or equal to (<=)

4 – Greater than (>)

5 – Greater than or equal to (>=)

6 – Between

7 – Contains

Parent Table
Alias

<pa> M The alias of the parent table.

Parent Table
Field

<pf> M The field in the parent table the join condition is
based on.

Parent Table <pt> M The parent table in the join condition.

Query <q> Y Encapsulates a query.

Maximum
Rows

<r> Y The maximum number of rows the query should
return.

Selected <s> Y If the <s> tag appears below the <f> tag, it
indicates whether the field will be returned as part
of the query's result set.
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Name Tag Required Description

System <s> Y If the <s> tag appears below the <q> tag, it
identifies the type of system this query is used
against (currently only SAP is supported).

Server
Filename

<sf> B Identifies the file on the server that holds the
results of a Background mode query.

Table <t> Y The table.

Table
Description

<td> Y The table description from the SAP data dictionary.
It should always appear below the <a> tag.

Tables <ts> Y The list of tables from which the query will extract
data.

Username <u> N The user’s logon name.

Filter <w> W The filter applied to the table’s data.

Filters <wc> W The list of filters that will be applied to the data
contained within the table.

Example

The following example illustrates a multi-table query using the IMPORT SAP command. The correct order and
nesting of the tags is necessary to create a valid query string. The example includes an IMPORT SAP command
with the tags nested in the correct order. Use this example to determine the required order of the query tags.

Although this example spans multiple lines, this is done for readability only. The command in your script must
be entered on a single line.

Tip

The syntax for the IMPORT SAP command is typically very complex. The best
way to add IMPORT SAP commands to your scripts is to copy an existing
IMPORT SAP command from the Log tab in ACL, then edit the query tags as
necessary.

IMPORT SAP PASSWORD 1 TO Purchasing_doc SAP SOURCE "SAP AGENT" 
<q version="6.0">
  <s>0</s>
  <d>IDES</d>
  <u>mzunini</u>
  <c>800</c>
  <lg>en</lg> 
  <cf>C:\ACL Data\Purchasing_doc.fil</cf>
  <sf>E:\Data\DL_JSMITH111107.DAT</sf>
  <jcount>11110701</jcount>
  <jname>DL_JSMITH111107.DAT</jname>
  <dl>75</dl>
  <m>1</m>
  <r>500</r>
  <ar>0</ar>
  <e>500</e>
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  <ts>
    <t>
      <n>EKKO</n>
      <a>T00001</a>
      <td>Purchasing Document Header</td>
      <fs>
        <f>EBELN</f>
        <f>BUKRS</f>
        <f>BSTYP</f>
        <f>BSART</f>
        <f>STATU</f>
        <f>WKURS</f>
      </fs>
      <wc>
        <w>
           <f>BUKRS</f>
           <o>0</o>
           <l>1000</l>
           <h></h>
        </w>
      </wc>
    </t>
    <t>
      <n>EKPO</n>
      <a>T00002</a>
      <td>Purchasing Document Item</td>
      <fs>
        <f>EBELP</f>
        <f>WERKS</f>
        <f>MENGE</f>
        <f>BRTWR</f>
      </fs>
      <wc></wc>
    </t>
  </ts>
  <js>
    <jc>
      <pt>
        <pa>T00001</pa>
        <pf>EBELN</pf>
      </pt>
      <ct>
        <ca>T00002</ca>
        <cf>EBELN</cf>
      </ct>
    </jc>
  </js>
</q>

Related concepts
About ACLScript commands

Related reference
RETRIEVE command
REFRESH command

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/c_about_aclscript_commands.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/r_retrieve.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/r_refresh.html
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6.3. RETRIEVE command
Use this command to retrieve the results of Direct Link queries submitted for background processing.

Syntax
RETRIEVE table_name PASSWORD n

Parameters

table_name

Specifies the name of the table originally created in ACL by the Direct Link query.

PASSWORD n

Specifies the password required to access the SAP system. If the required password value is not defined
before the RETRIEVE command is executed, ACL will prompt the user for their SAP password.

Tip

Use the SET PASSWORD command to define the password in the script before
using the RETRIEVE command, or specify the password on the command
line before running the script if you are running it from a Windows
shortcut.

Example

The following example sets the password and then retrieves the Background mode query results for an ACL
table named DD02T_Data.

SET PASSWORD 1 = “pwd” 
RETRIEVE DD02T_Data PASSWORD 1

Related concepts
About ACLScript commands

Related reference
IMPORT SAP command
REFRESH command

6.4. REFRESH command
Use this command to refresh the data in ACL tables that were originally created by Direct Link queries.

Syntax
REFRESH <table_name> <PASSWORD n>

Parameters

table_name

The name of the table that was originally created in ACL by the Direct Link query.

PASSWORD n

Specifies the password required to access the SAP system. If the required password value is not defined
before the REFRESH command is executed, ACL will prompt the user for their SAP password.

Tip

Use the SET PASSWORD command to define the password in the script before
using the REFRESH command, or specify the password on the command

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/c_about_aclscript_commands.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/r_import_sap.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/r_refresh.html
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line before running the script.

Example

The following line shows an example of the REFRESH command:

REFRESH DD02T_Data PASSWORD 1

Related concepts
About ACLScript commands

Related tasks
Refreshing SAP data

Related reference
IMPORT SAP command
RETRIEVE command

https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/c_about_aclscript_commands.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/ui/t_refreshing_sap_data.html
https://help.highbond.com/acl/dl/61/topic/com.acl.dl.user_guide.help/commands/r_import_sap.html
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